Website and digital product order processing disruption
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved. If you experienced any issues, please contact us at support.wwnorton.com/request
Posted Apr 30, 2022 - 09:53 EDT
Investigating
We are currently investigating an issue with order processing for product purchases. Access to existing digital products is not impacted. If you need help as we work to resolve this, please contact our Support team via support.wwnorton.com/request
Posted Apr 30, 2022 - 08:36 EDT
This incident affected: wwnorton.com (main website), Norton Ebooks, InQuizitive, Smartwork5, Norton Testmaker, and Additional Digital Resources.