Search and catalog view not working on wwnorton.com
Incident Report for W. W. Norton & Company, Inc.
Resolved
This issue has been resolved. Should you have questions or encounter further issues with our search or catalog, please contact us via https://support.wwnorton.com/request
Posted Nov 07, 2024 - 12:40 EST
Investigating
The search and catalog functions are currently not working on wwnorton.com. Our team is working on the resolution, and we will post updates here. Should you need help in the meantime, please contact us via support.wwnorton.com/request
Posted Nov 07, 2024 - 11:59 EST
This incident affected: wwnorton.com (main website).