This incident has been resolved. If you need additional help, please contact us via support.wwnorton.com/request
Posted Aug 27, 2025 - 10:02 EDT
Monitoring
We have implemented a fix to resolve earlier problems with credit card purchases and are monitoring our systems for stability. Access to previously purchased products has not been impacted. If a previous purchase attempt failed, please retry. If you continue to experience problems completing a purchase, please contact our support team via support.wwnorton.com/request
Posted Aug 27, 2025 - 00:25 EDT
Investigating
We are investigating reports of credit card purchase errors. Please subscribe to this page for updates. If you need assistance in the meantime, please contact our support team at support.wwnorton.com/request
Posted Aug 26, 2025 - 21:52 EDT
This incident affected: wwnorton.com (main website), Norton Ebooks, Norton Illumine, InQuizitive, and Smartwork5.