Website Password Reset Issue
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved. If you experienced any issues during the outage, please contact our Support team: https://support.wwnorton.com/request
Posted May 13, 2020 - 10:27 EDT
Monitoring
We have identified the issue and implemented a fix. We are now monitoring the site to confirm that it is working correctly again.
Posted May 13, 2020 - 09:27 EDT
Investigating
We are investigating an issue where customers are not able to reset passwords to wwnorton.com. Our team is looking into this and we'll provide an update as quickly as possible. For assistance, please contact our support team: https://support.wwnorton.com/request.
Posted May 13, 2020 - 00:01 EDT
This incident affected: wwnorton.com (main website).