Online purchase disruption
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved. If you need additional assistance, please contact our support team: https://wwnorton.com/help
Posted Aug 28, 2019 - 19:52 EDT
Investigating
We are currently experiencing an issue with our digital products that limits customers’ ability to make purchases. Registration codes are working normally. Please use Trial Access if you need immediate access to products. Our team is working quickly to identify the root cause and implement a solution.
Posted Aug 28, 2019 - 19:05 EDT
This incident affected: Norton Ebooks, InQuizitive, Smartwork5, and Additional Digital Resources.