Digital Landing Pages loading error

Incident Report for W. W. Norton & Company, Inc.

Resolved

This incident has been resolved. If you have any remaining questions or issues please contact us at support.wwnorton.com
Posted Aug 21, 2025 - 13:42 EDT

Monitoring

We have identified and implemented a fix for the loading issue. We will monitor the fix and provide an update when our validation is complete. If you continue to experience any issues please let us know at support.wwnorton.com
Posted Aug 20, 2025 - 18:00 EDT

Investigating

We are currently investigating reports of Norton Digital Landing Page loading issues. We will provide more updates as they become available.
Posted Aug 20, 2025 - 15:49 EDT
This incident affected: Norton Ebooks, Norton Illumine, InQuizitive, and Smartwork5.