Credit Card Purchasing Issue

Incident Report for W. W. Norton & Company, Inc.

Resolved

This incident has been resolved.
Posted Apr 21, 2025 - 11:07 EDT

Investigating

We are investigating an issue with new purchases in which some users have reported receiving an error message when using a credit card. Access to products using existing accounts is not impacted. Should you need assistance please contact our Support team: https://support.wwnorton.com/request
Posted Apr 21, 2025 - 02:38 EDT
This incident affected: wwnorton.com (main website) and Additional Digital Resources.