Errors with logins and purchases in Norton digital products
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved. If you continue to experience problems, please contact Norton's support team: https://wwnorton.com/help
Posted Jul 12, 2024 - 16:55 EDT
Monitoring
A fix has been implemented. Login and purchases are back online. We will monitor for any remaining issues. If you continue to experience problems, please contact Norton's support team: https://wwnorton.com/help
Posted Jul 12, 2024 - 16:32 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 12, 2024 - 16:19 EDT
Investigating
We are currently investigating reports of users unable to log in or make purchases across several Norton digital products. We will provide updates as we make progress with the investigation.
Posted Jul 12, 2024 - 15:48 EDT
This incident affected: wwnorton.com (main website), Norton Ebooks, Norton Illumine, InQuizitive, Smartwork5, and Additional Digital Resources.