Amazon AWS outage - partial disruptions

Incident Report for W. W. Norton & Company, Inc.

Resolved

The Amazon AWS issue has been resolved.
Posted Oct 21, 2025 - 09:24 EDT

Monitoring

There is a widespread Amazon AWS outage causing disruptions to many of our partners. While Norton products and services have not been directly impacted, users accessing our platform through an LMS or other vendor partner might experience intermittent access issues due to the impact of the AWS outage on those platforms.

You can track updates to the Amazon AWS outage on their Status page here: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 17:08 EDT
This incident affected: Norton Ebooks, Norton Illumine, InQuizitive, Smartwork5, and Additional Digital Resources.