Intermittent digital product issue on wwnorton.com

Incident Report for W. W. Norton & Company, Inc.

Resolved

This issue has been resolved. If you experience any further issue accessing your digital products, please contact support.wwnorton.com/request.
Posted Jun 30, 2026 - 19:33 EDT

Investigating

We are investigating an intermittent issue where digital products are not appearing in the customer dashboard. We will post updates here. If you are experiencing this issue, please contact support.wwnorton.com/request for help.
Posted Jun 30, 2026 - 15:34 EDT
This incident affected: wwnorton.com (main website).