Credit card transaction issue
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved.
Posted Jun 13, 2021 - 10:25 EDT
Investigating
We are investigating reports of credit card transaction failures for digital product purchases. If you require assistance while we resolve this, please contact our Support Team via support.wwnorton.com/request.
Posted Jun 13, 2021 - 10:13 EDT
This incident affected: wwnorton.com (main website), Norton Ebooks, InQuizitive, and Smartwork5.