Technical Support form on the website not accepting submissions
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved.
Posted Apr 08, 2020 - 21:19 EDT
Investigating
We are currently investigating reports that customers are not able to submit the form requesting technical support. Our development team is working on this problem, and we hope to resolve it soon.
Posted Apr 08, 2020 - 21:11 EDT
This incident affected: wwnorton.com (main website).