Website issue with browsing categories of book
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved.
Posted May 05, 2020 - 19:55 EDT
Identified
We are experiencing an issue with the browsing functionality of the website where books are appearing in the wrong categories. The search function is working properly so visitors to the site should use the search bar to find titles until the browsing issue is resolved.
Posted May 05, 2020 - 12:19 EDT
This incident affected: wwnorton.com (main website).