Canadian payment processing outage
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved and Canadian students can make purchases at this time. If you continue to experience issues, please contact our Support team via support.wwnorton.com/request
Posted May 16, 2024 - 11:42 EDT
Investigating
We are currently experiencing an issue processing payments for Canadian customers for digital product purchases. Access to existing digital products is not impacted. Students may register for trial access or redeem a code without issue. If you need help as we work to resolve this, please contact our Support team via support.wwnorton.com/request
Posted May 16, 2024 - 11:11 EDT
This incident affected: wwnorton.com (main website).