Website and digital product order processing disruption
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved.
Posted Aug 14, 2023 - 16:10 EDT
Monitoring
Purchasing systems are now operational. We will continue to monitor this incident and provide further updates if necessary.
Posted Aug 14, 2023 - 15:38 EDT
Update
We are continuing to investigate this issue. Another update will be provided within three hours.
Posted Aug 14, 2023 - 14:18 EDT
Investigating
We are currently investigating an issue with order processing for product purchases. Access to existing digital products is not impacted. If you need help as we work to resolve this, please contact our Support team via support.wwnorton.com/request
Posted Aug 14, 2023 - 13:16 EDT
This incident affected: wwnorton.com (main website).