We are investigating reports that wwnorton.com and the digital products are facing sporadic loading issues. We will provide an update within the hour. Contact the support desk for assistance: support.wwnorton.com/request.
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved. If you are facing any issues accessing the Norton website and digital products, please contact: https://support.wwnorton.com/request
Posted Apr 05, 2023 - 11:02 EDT
Update
We are continuing to investigate this issue.
Posted Apr 04, 2023 - 13:38 EDT
Investigating
We are currently investigating this issue.
Posted Apr 04, 2023 - 12:21 EDT
This incident affected: wwnorton.com (main website), Norton Ebooks, Norton Illumine, InQuizitive, Smartwork5, Norton Testmaker, and Additional Digital Resources.