Tech Support forms on the website intermittently not accepting submissions
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved.
Posted Nov 14, 2020 - 17:24 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 14, 2020 - 15:36 EST
Identified
The issue has been identified and our teams are working to resolve it. If you require assistance, please contact our support team at https://wwnorton.com/tech-support.
Posted Nov 14, 2020 - 08:30 EST
Investigating
We are currently investigating reports that customers are intermittently encountering error messages when trying to submit tech support forms. Our teams are working to resolve this issue. If you require assistance, please contact our support team at https://wwnorton.com/tech-support.
Posted Nov 13, 2020 - 21:30 EST
This incident affected: wwnorton.com (main website).