Credit Card transaction issue
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved.
Posted Aug 16, 2021 - 10:55 EDT
Monitoring
A fix has been implemented and the team is monitoring the results. If you experience any problems, please contact our Support Team via support.wwnorton.com/request.
Posted Aug 16, 2021 - 10:22 EDT
Investigating
We are investigating reports of credit card transaction failures on wwnorton.com. If you require assistance while we resolve this, please contact our Support Team via support.wwnorton.com/request.
Posted Aug 16, 2021 - 10:01 EDT
This incident affected: wwnorton.com (main website).