Website and digital order processing disruption
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved. If you need additional assistance, please contact us via support.wwnorton.com/request
Posted Jul 22, 2024 - 08:41 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 22, 2024 - 07:11 EDT
Investigating
We are currently investigating an issue with order processing for new product purchases. Customers are unable to complete new purchases or create new accounts. Access to existing digital product accounts is not impacted. If you need help as we work to resolve this, please contact our Support team via support.wwnorton.com/request
Posted Jul 22, 2024 - 02:45 EDT
This incident affected: wwnorton.com (main website), Norton Ebooks, Norton Illumine, InQuizitive, Smartwork5, Norton Testmaker, and Additional Digital Resources.