Investigating intermittent issues with credit card processing
Incident Report for W. W. Norton & Company, Inc.
Resolved
This issue has been resolved. If you experienced any issues, please contact us via support.wwnorton.com/request.
Posted Aug 30, 2023 - 08:29 EDT
Monitoring
A fix has been implemented and we are monitoring the system to ensure that the intermittent credit card processing issue is resolved. If you need assistance, please contact our support team via support.wwnorton.com/request.
Posted Aug 30, 2023 - 01:27 EDT
Investigating
We are investigating reports of intermittent issues with credit card processing on digital product orders. We will post updates to this status page and you can contact us via support.wwnorton.com/request if you need assistance in the meantime.
Posted Aug 29, 2023 - 23:42 EDT
This incident affected: wwnorton.com (main website), Norton Ebooks, Norton Illumine, InQuizitive, and Smartwork5.