Digital products and website service disruption
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved. If you need additional assistance, please contact our support team: https://wwnorton.com/help
Posted Aug 26, 2019 - 14:02 EDT
Monitoring
Our team has implemented a fix and will continue to monitor the website and digital products. If you continue to experience any issues, or if you need additional assistance, please contact our support team: https://wwnorton.com/help
Posted Aug 26, 2019 - 12:08 EDT
Investigating
We are currently experiencing an issue with our website and digital products that limits customers' ability to login, purchase Norton products, or access instructor resources. Our team is working quickly to identify the root cause and implement a solution.
Posted Aug 26, 2019 - 11:10 EDT
This incident affected: wwnorton.com (main website), Norton Ebooks, InQuizitive, Smartwork5, and Additional Digital Resources.