Reports of slow loading times for InQuizitive and other digital products
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved. If you require assistance, please contact Norton support at https://support.wwnorton.com/request
Posted Feb 21, 2021 - 20:59 EST
Monitoring
A fix has been implemented, and we are monitoring results. If you require assistance, please contact Norton support at https://support.wwnorton.com/request
Posted Feb 21, 2021 - 20:36 EST
Investigating
We are currently investigating reports of slow loading times for Norton Learning Tools. If you require assistance, please contact Norton support at https://support.wwnorton.com/request
Posted Feb 21, 2021 - 20:13 EST
This incident affected: Norton Ebooks, InQuizitive, Smartwork5, and Additional Digital Resources.