Purchasing and Account Creation Issue

Incident Report for W. W. Norton & Company, Inc.

Resolved

This is issue is now resolved. Users should now be able to create new accounts and purchase as usual. We will continue to monitor this, but should you need assistance, please contact our Support team: https://support.wwnorton.com/request
Posted Apr 22, 2025 - 11:34 EDT

Investigating

We are investigating an issue with new purchases in which some users have reported receiving an error message when using a credit card. Access to products using existing accounts is not impacted. Should you need assistance please contact our Support team: https://support.wwnorton.com/request
Posted Apr 22, 2025 - 06:34 EDT
This incident affected: wwnorton.com (main website) and Additional Digital Resources.