Interactive Instructor's Guides not loading
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved.
Posted Dec 14, 2022 - 11:36 EST
Update
The issue has been resolved, and Interactive Instructor's Guides are now loading. Thank you for your patience as we resolved the issue.
Posted Dec 14, 2022 - 11:34 EST
Investigating
We are investigating reports that our Interactive Instructor's Guides are not loading. We will provide updates here. If you require assistance while we resolve this, please contact our Support Team via support.wwnorton.com/request.
Posted Dec 13, 2022 - 17:32 EST
This incident affected: Additional Digital Resources.