Support Ticket Submissions

Incident Report for W. W. Norton & Company, Inc.

Resolved

This incident has been resolved. We will continue to monitor support form submissions to ensure there are no further issues.
Posted Mar 08, 2025 - 20:34 EST

Investigating

Users are currently unable to submit support tickets. We are investigating this issue and will post an update soon. Thank you for your patience.
Posted Mar 08, 2025 - 18:36 EST
This incident affected: wwnorton.com (main website).