Instructor Resource Access
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved.
Posted Jun 25, 2019 - 09:35 EDT
Investigating
Instructor resources are currently inaccessible from the website, so please contact your local representative if you need assistance while we work to restore this service.
Posted Jun 25, 2019 - 08:21 EDT
This incident affected: Additional Digital Resources.