Loading delays observed for InQuizitive and Smartwork
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved.
Posted Jun 19, 2020 - 10:42 EDT
Update
We are continuing to investigate this issue.
Posted Jun 18, 2020 - 18:38 EDT
Investigating
We are currently investigating reports of delays loading InQuizitive and Smartwork activities. Our team is working to identify the root cause and implement a solution.
Posted Jun 18, 2020 - 11:32 EDT
This incident affected: InQuizitive and Smartwork5.