Select videos and flashcards loading issue
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved. If you continue to experience issues, please contact our support team at https://support.wwnorton.com/request.
Posted Jul 16, 2024 - 09:40 EDT
Investigating
We are investigating an issue where some flashcards and videos on our website are failing to load. We will provide updates as we make progress with the investigation.
Posted Jul 15, 2024 - 12:18 EDT
This incident affected: wwnorton.com (main website) and Additional Digital Resources.