Website currently unavailable (wwnorton.com)
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved. If you experienced any issues during the outage, please contact our Support team: https://support.wwnorton.com/request
Posted May 13, 2020 - 10:27 EDT
Monitoring
We have identified the issue and implemented a fix. The website should now be functioning properly and we are continuing to monitor it. If you experienced any issues during the outage, please contact our Support team: https://support.wwnorton.com/request
Posted May 13, 2020 - 09:18 EDT
Investigating
The wwnorton.com website is currently unavailable. We are actively investigating the issue. Digital products such as ebooks, InQuizitive and Smartwork appear to be unaffected at this time.
Posted May 13, 2020 - 08:37 EDT
This incident affected: wwnorton.com (main website).