This intermittent issue has been resolved. We will continue to monitor the wwnorton.com catalog and will provide updates here if required. If you need assistance, please contact our support team at support.wwnorton.com/request
Posted Sep 17, 2025 - 11:51 EDT
Update
We are continuing to investigate this intermittent issue. We'll post another update as soon as we identify the root cause. If you need assistance, please contact our support team at support.wwnorton.com/request
Posted Sep 16, 2025 - 10:38 EDT
Investigating
We are currently investigating an intermittent issue where book covers and other metadata are not displaying properly in the wwnorton.com catalog and search results. You should not encounter any issue clicking on the book or purchasing it during this time. If you need assistance, please contact our support team at support.wwnorton.com/request
Posted Sep 15, 2025 - 22:10 EDT
This incident affected: wwnorton.com (main website).