Digital product purchasing for Canadian customers temporarily unavailable

Incident Report for W. W. Norton & Company, Inc.

Resolved

Purchasing of digital products has been restored for Canadian customers. If you experience any further purchasing issues, please contact us via support.wwnorton.com/request.
Posted Aug 25, 2025 - 22:32 EDT

Investigating

Purchasing of digital products is temporarily unavailable for Canadian customers as our Canadian distribution partner investigates an issue. We will continue to monitor the situation and provide updates on progress here. Access for existing customers in not impacted. If you need help as the team works to resolve this, please contact us via support.wwnorton.com/request.
Posted Aug 25, 2025 - 13:25 EDT
This incident affected: Norton Ebooks, Norton Illumine, InQuizitive, and Smartwork5.