New account creation and purchases currently unavailable

Incident Report for W. W. Norton & Company, Inc.

Resolved

This incident has been resolved, though we are continuing to monitor orders. If you experienced any issues, please contact us at support.wwnorton.com/request
Posted May 09, 2023 - 12:35 EDT

Investigating

We have identified an issue with our website and digital products where customers are currently unable to purchase or create new accounts. Our team is working on the issue and will post updates here. If you need help in the meantime, please contact our Support team via support.wwnorton.com/request
Posted May 09, 2023 - 11:24 EDT
This incident affected: wwnorton.com (main website), Norton Ebooks, Norton Illumine, InQuizitive, Smartwork5, Norton Testmaker, and Additional Digital Resources.