Purchasing issue on wwnorton.com

Incident Report for W. W. Norton & Company, Inc.

Resolved

This issue is now resolved. If you experience any issue making a purchase on wwnorton.com, please contact our Support team: https://support.wwnorton.com/
Posted Aug 17, 2026 - 16:47 EDT

Investigating

We are currently investigating an issue where customers cannot complete purchases on wwnorton.com. Customers are facing an issue where they cannot move past the step where they enter their zip code. If you are experiencing this issue, please contact our Support team, who will help you complete your purchase: https://support.wwnorton.com/
Posted Aug 17, 2026 - 15:29 EDT
This incident affected: wwnorton.com (main website).