Slow loading times on Chrome
Incident Report for W. W. Norton & Company, Inc.
Resolved
This issue has been resolved. We will continue to monitor for any further issues. If you have questions, please contact Support at https://support.wwnorton.com/request
Posted Jan 26, 2024 - 10:23 EST
Investigating
We are currently investigating reports of slow loading times on wwnorton.com for visitors using Chrome. If you experience this issue, please use a different browser in the interim. If you have questions, please contact Support at https://support.wwnorton.com/request
Posted Jan 25, 2024 - 12:05 EST
This incident affected: wwnorton.com (main website).