Purchase failures on wwnorton.com

Incident Report for W. W. Norton & Company, Inc.

Resolved

This incident has been resolved.
Posted Jul 12, 2026 - 18:03 EDT

Monitoring

The issue has been fixed and we are monitoring the site. If you continue to experience any issues, please contact support.wwnorton.com/request.
Posted Jul 12, 2026 - 16:38 EDT

Investigating

We are investigating reports of purchase failure on https://wwnorton.com/. We will post updates here. If you are experiencing this issue, please contact support.wwnorton.com/request for help.
Posted Jul 12, 2026 - 16:05 EDT
This incident affected: wwnorton.com (main website).