Disrupted Access to Norton Flashcards
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved.
Posted Oct 14, 2021 - 18:12 EDT
Investigating
We are currently investigating reports that customers cannot access Norton Flashcards. If you require assistance, please contact Norton support at https://support.wwnorton.com/request
Posted Oct 14, 2021 - 17:07 EDT
This incident affected: Additional Digital Resources.