Smartwork Issue
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved.
Posted Jun 08, 2020 - 10:54 EDT
Investigating
We are currently experiencing an issue with Smartwork where some instructors may not be able to access the application. We are investigating and will provide an update as soon as we can.
Posted Jun 08, 2020 - 10:43 EDT
This incident affected: Smartwork5.