Digital Landing Page Issues
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved.
Posted Nov 13, 2019 - 07:57 EST
Monitoring
We are continuing to monitor this incident.
Posted Nov 12, 2019 - 22:05 EST
Investigating
We are currently investigating problems related to Digital Landing Pages and will update this status once we know more.
Posted Nov 12, 2019 - 18:16 EST
This incident affected: Additional Digital Resources.