Textbook purchase options display issue on wwnorton.com
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved.
Posted Nov 30, 2021 - 17:17 EST
Identified
We've identified an issue with the display of hardcopy textbook purchase options on wwnorton.com. Some textbook formats are not showing. Digital product purchase options are displaying correctly. Our team is working to resolve the issue. If you need assistance in the meantime to confirm textbook format options, pricing, or to make a purchase of a hardcopy book, please contact us via support.wwnorton.com/request
Posted Nov 30, 2021 - 16:18 EST
This incident affected: wwnorton.com (main website).