Exam/Desk Copy Request temporarily not available on wwnorton.com
Incident Report for W. W. Norton & Company, Inc.
Resolved
The issue has been resolved and Exam/Desk copy requests for instructors are now getting processed. If you placed an exam copy order and saw an error message, you do not need to take further action. We are able to process those requests. For any other questions or concerns, please contact our support team via support.wwnorton.com/request
Posted Oct 26, 2021 - 15:49 EDT
Identified
We are investigating an issue where the exam/desk copy request for instructors is not working on wwnorton.com and order requests are not getting processed. Please hold on submitting requests until the matter is resolved. We will provide confirmation here when the issue is resolved..
Posted Oct 26, 2021 - 12:53 EDT
This incident affected: wwnorton.com (main website).