Smartwork degraded performance
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved.
Posted Aug 20, 2022 - 12:55 EDT
Investigating
We have received reports that some images are not appearing in Smartwork assignments. We are looking into this and hope to resolve it quickly. Thank you for your patience.
Posted Aug 20, 2022 - 12:31 EDT
This incident affected: Smartwork5.