Reports of slow loading times in Norton digital products
Incident Report for W. W. Norton & Company, Inc.
Resolved
The Norton team has implemented measures to resolve the slow loading times in digital products and performance has improved. If you require assistance, please contact Norton support at https://support.wwnorton.com/request
Posted Feb 09, 2021 - 11:04 EST
Investigating
We are investigating reports that some customers are experiencing intermittent slow loading times in Norton's digital products. If you require assistance, please contact Norton support at https://support.wwnorton.com/request
Posted Feb 08, 2021 - 22:32 EST
This incident affected: Norton Ebooks, InQuizitive, and Smartwork5.