Reports of error messages when accessing instructor content in Norton Teaching Tools/ Interactive Instructor Guides
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved. If you experienced any issues, please contact us at support.wwnorton.com/request
Posted Jul 06, 2023 - 13:33 EDT
Investigating
We are investigating reports of error messages when trying to access instructor content in the Norton Teaching Tools/ Interactive Instructor's Guide instructor resources. We will continue to provide updates here. If you require assistance while we resolve this, please contact our Support Team via support.wwnorton.com/request.
Posted May 19, 2023 - 11:03 EDT
This incident affected: Additional Digital Resources.