System maintenance impacting new purchases and password changes

Incident Report for W. W. Norton & Company, Inc.

Resolved

This incident has been resolved.
Posted Apr 17, 2025 - 19:58 EDT

Update

We are continuing to monitor for any further issues.
Posted Apr 17, 2025 - 19:50 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 17, 2025 - 19:49 EDT

Identified

The W. W. Norton website and digital products are undergoing necessary system maintenance. New account creation, online purchases, and password changes will not be possible during this time. Access to products using existing accounts will not be impacted. Should you need assistance please contact our Support team: https://support.wwnorton.com/request
Posted Apr 17, 2025 - 16:30 EDT
This incident affected: wwnorton.com (main website), Norton Ebooks, Norton Illumine, InQuizitive, Smartwork5, Norton Testmaker, and Additional Digital Resources.