Chrome browser and website display issue
Incident Report for W. W. Norton & Company, Inc.
Resolved
This issue has been resolved.
Posted Aug 05, 2020 - 09:52 EDT
Identified
Certain pages on wwnorton.com are not displaying correctly when using the Chrome browser. We have identified the issue and will release a fix within 24 hours. The website displays correctly in other browsers such as Safari and Firefox.
Posted Jul 23, 2020 - 09:11 EDT
This incident affected: wwnorton.com (main website).