Norton Ebook Reader Beta fails to load with "Service Unavailable"
Incident Report for W. W. Norton & Company, Inc.
Resolved
The issue leading some Norton Ebook Reader beta users to a "Service Unavailable" error is now resolved. If you continue to experience an error, please reach out to our support team: https://support.wwnorton.com/request
Posted Jun 28, 2022 - 16:59 EDT
Investigating
We are currently investigating an issue where users in the beta version of the Norton Ebook Reader encounter a "Service Unavailable" error. We will provide updates as we work to resolve the problem. In the meantime, please submit a support ticket if you encounter this error: https://support.wwnorton.com/request
Posted Jun 28, 2022 - 12:54 EDT
This incident affected: Norton Ebooks.