Website and Help Desk service disruption
Incident Report for W. W. Norton & Company, Inc.
Resolved
The updates are now complete.
Posted Apr 18, 2020 - 14:50 EDT
Identified
Due to necessary updates for Norton systems this morning, customers will be temporarily unable to contact the Help Desk or request examination copies. Our teams are working quickly and we will confirm when the work is complete.
Posted Apr 18, 2020 - 08:03 EDT
This incident affected: wwnorton.com (main website).