Slow loading on product pages

Incident Report for W. W. Norton & Company, Inc.

Resolved

This incident has been resolved.
Posted Jun 22, 2023 - 11:57 EDT

Investigating

We are currently investigating reports of slow loading times on the product pages that house Norton resources such as Ebooks, InQuizitive, and Smartwork. We will provide updates here. If you require assistance while we resolve this, please contact our Support Team via support.wwnorton.com/request.
Posted Jun 22, 2023 - 11:53 EDT
This incident affected: Norton Ebooks, Norton Illumine, InQuizitive, and Smartwork5.