Intermittent slow loading of digital products
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved.
Posted Aug 28, 2024 - 15:59 EDT
Monitoring
We have made adjustments to our infrastructure and this issue should now be resolved. We will continue monitoring to ensure that all digital products are fully operational. If you experience any problems, please contact Norton's support team at https://support.wwnorton.com/request
Posted Aug 28, 2024 - 13:43 EDT
Investigating
We are currently investigating reports of digital products loading slowly. We'll provide more updates as they become available.
Posted Aug 28, 2024 - 13:03 EDT
This incident affected: Norton Ebooks, Norton Illumine, InQuizitive, and Smartwork5.