Website and digital product log-in issue
Incident Report for W. W. Norton & Company, Inc.
Resolved
This incident has been resolved and users should now be able to log in and create new accounts. If you are experiencing any remaining issues, please contact our support team: https://support.wwnorton.com/request
Posted Mar 26, 2020 - 20:28 EDT
Investigating
We are investigating an issue where customers are not able to create accounts or log in to wwnorton.com or digital product pages. Our team is looking into this and we'll provide an update as quickly as possible.
Posted Mar 26, 2020 - 16:59 EDT
This incident affected: wwnorton.com (main website), Norton Ebooks, InQuizitive, Smartwork5, and Additional Digital Resources.